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1. Introduction 

The “Control Panel” is designed to assist the users to simulate directly from CellDesigner 

controlling the amounts and parameters of the Species. 

Calling directly SBML ODE Solver (http://www.tbi.univie.ac.at/~raim/odeSolver/) from 

CellDesigner, ControlPanel enables you to specify the details of parameters, changing amount, 

conducting parameter search, and interactive simulation with intuitive manner. 

You can also choose COPASI or Simulation Core Library as an alternative solver.  

Please check the detail specification of each solver/simulator at its own website. 

 See also:  

SBML ODE Solver (http://www.tbi.univie.ac.at/~raim/odeSolver/) 

COPASI (http://www.copasi.org/) 

Simulation Core Library (http://sourceforge.org/projects/simulation-core) 

 

 See also: Startup Guide  

 

Sample file used in this document: 

This document uses a sample model “MAPK.xml” originally provided with SBML ODE Solver. 

When you install CellDesigner, MAPK.xml is deployed in the /<your CellDesigner 

directory>/samples/ folder. 

This MAPK.xml model has been slightly modified from a model obtained from 

http://sbml.org/models/. 

http://www.tbi.univie.ac.at/~raim/odeSolver/
http://www.tbi.univie.ac.at/~raim/odeSolver/
http://www.copasi.org/
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The model has been published in Kholodenko BN. Negative feedback and ultrasensitivity can 

bring about oscillations in the mitogen-activated protein kinase cascades. Eur. J. Biochem. 

267: 1583-1588 (2000). 



Running CellDesigner
TM 

Simulation with ControlPanel 

6 CD10D00 

2. Quick Tutorial of Simulation 

2.1 Before you start simulation 

Throughout this tutorial, we will use MAPK.xml, which can be found in the <CellDesigner 

installation directory>/samples/ folder. All the formulae necessary for the simulation are 

already embedded in the Reactions. You can check the formulae in the CellDesigner’s 

Reactions list. 

 See also: Startup Guide or CellDesigner Online Help. 

 

KineticLaw 

id name reactants products modifiers math 

J0 J0 MKKK MKKK_P MAPK_PP 
V1 * MKKK / ((1 + pow(MAPK_PP / Ki, n)) 

* (K1 + MKKK)) 

J1 J1 MKKK_P MKKK  V2 * MKKK_P / (KK2 + MKKK_P) 

J2 J2 MKK MKK_P MKKK_P k3 * MKKK_P * MKK / (KK3 + MKK) 

J3 J3 MKK_P MKK_PP MKKK_P k4 * MKKK_P * MKK_P / (KK4 + MKK_P) 

J4 J4 MKK_PP MKK_P  V5 * MKK_PP / (KK5 + MKK_PP) 

J5 J5 MKK_P MKK  V6 * MKK_P / (KK6 + MKK_P) 

J6 J6 MAPK MAPK_P MKK_PP k7 * MKK_PP * MAPK / (KK7 + MAPK) 

J7 J7 MAPK_P MAPK_PP MKK_PP 
k8 * MKK_PP * MAPK_P / (KK8 + 

MAPK_P) 

J8 J8 MAPK_PP MAPK_P  V9 * MAPK_PP / (KK9 + MAPK_PP) 

J9 J9 MAPK_P MAPK  V10 * MAPK_P / (KK10 + MAPK_P) 
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Species 

class id name compartment quantity type initialQuantity 

PROTEIN MKK MKK uVol Amount 280 

PROTEIN MKKK MKKK uVol Amount 90 

PROTEIN MAPK MAPK uVol Amount 280 

PROTEIN MKKK_P MKKK uVol Amount 10 

PROTEIN MKK_P MKK uVol Amount 10 

PROTEIN MKK_PP MKK uVol Amount 10 

PROTEIN MAPK_P MAPK uVol Amount 10 

PROTEIN MAPK_PP MAPK uVol Amount 10 

Parameters 

scope id name value units constant 

local:Reaction(J0) V1  2.5  TRUE 

local:Reaction(J0) Ki  9  TRUE 

local:Reaction(J0) n  1  TRUE 

local:Reaction(J0) K1  10  TRUE 

local:Reaction(J1) V2  0.25  TRUE 

local:Reaction(J1) KK2  8  TRUE 

local:Reaction(J2) k3  0.025  TRUE 

local:Reaction(J2) KK3  15  TRUE 

local:Reaction(J2) V0 V0 111  TRUE 

local:Reaction(J2) K0 K0 1  TRUE 

local:Reaction(J3) k4  0.025  TRUE 

local:Reaction(J3) KK4  15  TRUE 

local:Reaction(J4) V5  0.75  TRUE 

local:Reaction(J4) KK5  15  TRUE 

local:Reaction(J5) V6  0.75  TRUE 

local:Reaction(J5) KK6  15  TRUE 

local:Reaction(J6) k7  0.025  TRUE 

local:Reaction(J6) KK7  15  TRUE 

local:Reaction(J7) k8  0.025  TRUE 

local:Reaction(J7) KK8  15  TRUE 

local:Reaction(J8) V9  0.5  TRUE 

local:Reaction(J8) KK9  15  TRUE 

local:Reaction(J9) V10  0.5  TRUE 

local:Reaction(J9) KK10  15  TRUE 
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2.2 To run a basic simulation: 

1. Open the sample file MAPK.xml in the samples folder. 

2. In the Menu, select Simulation - ControlPanel. 

3. The ControlPanel dialog box appears. 

 

4. Click Execute button. 

5. A graph will be drawn in the right pane.  

 

6. By default, the simulation End Time is set to “100” and Num. of Points to plot is “100”. 

You can enter different values into End Time and Num. of Points to change these values. 

7. Change End Time to “1000”. 

    

8. Click Execute button. 

9. A graph is drawn with a longer time. 
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2.3 To view the values of the simulation results: 

1. Click the Table Tab behind the Graph tab in the right pane. 

2. You can view the results of the simulation in a table format. You can switch species, 

fluxes, parameters and compartment by clicking the relevant tabs.  

 

 Note:  You can copy the data from the table by specifying the area in the table. The data is 

treated as CSV format so you can paste it directly to a spreadsheet. 

2.4 To save an image of the simulation result: 

You can save the graph image into five types of graphical file formats:  

BMP, JPEG, PNG, TIFF, and PNM file format: (".bmp", ".jpg", ".png", “.tif” and “.pnm”.) 

1. Select Save Image / Print from the File menu. 

2. The Image Config Dialog dialog box appears. 
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3. Click Config button to specify the graph items such as Title, Legend and Plot ranges. 

 

4. Click OK. 

Click Save Image button, then select the file format and specify the file name for a 

graph image. 
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2.5 To change the solver to COPASI or Simulation Core Library: 

COPASI is a software application for simulation and analysis of biochemical networks.  

Simulation Core Library is also a simulation software. You can choose the simulation solver of 

your choice for simulation of your model. 

1. Click the COPASI or SimulationCore radio button. 

2. Click Execute. 

 

 To install Copasi, see also README.txt or “Installation and Startup” section in 

CellDesigner’s Startup Guide, 

 

 Which solver to use for simulation? 

CellDesigner will check a model before running a simulation.    

Currently CellDesigner disables SOSlib when:  

  1. a model contains "delay" csymbol (which will be DDE)     

  2. a model contains <functionDefinition>     

  3. a model contains <algebraicRule>     

and disables COPASI when:     

  1. a model contains "Delay" csymbol.     

The reason is shown in pop-up message of each radio button. 

 

http://www.copasi.org/


Running CellDesigner
TM 

Simulation with ControlPanel 

12 CD10D00 

3. Change the Initial Quantities of Species and Parameter Values 

It is possible to run the simulation with the values in Species and Parameters tabs changed. 

The values changed in the ControlPanel are updated to the corresponding values in the 

CellDesigner itself. 

3.1 To change the initial quantity for Species: 

1. Click the Species tab. 

 

2. Change the initial quantity by clicking each blue cell for the values to be modified. 

3. Click Execute button to run the simulation with the new values. 

3.2 To change the parameter values: 

1. Click the Parameters tab. 

 

2. Change the initial parameters by clicking each blue cell for the values to be modified. 

3. Click Execute button to run the simulation with the new parameters. 
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4. Change Amount for Simulation 

In order to simulate the time course of Specie resulting from forced expression of a gene/genes 

on a certain time, ControlPanel implements the Change amount functionality. With this 

functionality, you can run a simulation with the amount of Species at a specific time being 

changed to a desired value. 

 Note: COPASI does not support the Change Amount functionality. 

4.1 To run simulation changing the amount of Species at specific time: 

1. Click the Change amount tab. 

2. Check the Change amount checkbox. 

3. In the Change amount matrix, enter the amount of Species at the time specified at the 

header row. 

 

4. Click the Execute button. 

4.2 To export and import the Change amount matrix: 

The Change amount matrix can be edited by external software such as MS Excel by exporting 

the matrix to a CSV file. Conversely, a CSV file edited outside can be imported to 

ControlPanel. 

1. Select Export from the Data menu. 

2. Enter a file name and click Save button. 

(A CSV file will be created with the specified file name.) 

3. Open the CSV file using other software such as MS Excel, edit values, and save them. 
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e.g. an example of .CSV file exported from Control Panel. 

4. Select Import from the Data menu. 

5. Select the file that you have just edited and click Open button. 
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5. Parameter Scan 

You can run simulations in a batch job to scan parameters. By setting the range and interval 

of each parameter to scan, ControlPanel runs the simulation with each parameter changing 

within the specified range with the value incremented by the specified interval. 

5.1 To scan parameters: 

1. Click the Parameter Scan tab. 

2. Check the Scan parameter checkbox. 

3. Select the Initial value or Parameter value option. 

4. Select the name of a parameter to change from the Name list. 

5. Input values into From, To, and Interval for a parameter scan, which correspond to the 

start value, the end value, and the interval respectively. 

6. Click Execute button to start simulation scanning of the specified parameters. 

 

 Note: If you check two Scan parameter checkboxes, you can scan two parameters. The 

simulations are executed using the combination of the two parameters. 

5.2 To see the results of parameter scan: 

1. If the message “The simulation was completed” is displayed in the Information dialog 

box, click OK. 

2. Click the flashing Result tab. (The rightmost tab) 

3. Select the result you want to see and click the Show Graph button. 

 Note: If you specify only one parameter on parameter scanning, you should specify Overlay 

Setting to view the graph. 
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5.3 To output the results of parameter scan: 

1. Click Writing. 

2. Specify the file name and the directory to save the file. 

3. The output of the parameter scan results will be saved in text file format. 
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6. Interactive Simulation 

ControlPanel allows you to see real-time results of simulations. You should use "Interactive 

simulation" for this purpose. 

6.1 To run interactive simulations: 

1. Click the Interactive Simulation tab. 

2. Select the Initial value or Parameter value option. 

3. To change a parameter, slide each slider bar or input a value into the box on the right 

side of the slider bar for that parameter.  

 

 Note: The minimum and maximum values of the slider bars were automatically defined 

based on the initial values of SBML. However, you can change the data range of the slider 

bars. 
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6.2 To change the data range of slider bars: 

1. Click the Define Range button. 

2. In the Define Slider Range dialog box, change the minimum and maximum values and 

click OK button. 
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7. Graph Area 

7.1 To highlight a Species in the Graph Area: 

1. In the Control Panel, click the Graph tab. 

2. Click a cell in the Species column in the table. 

3. The corresponding line in the Graph will be highlighted. 

4. Next, click a line in the Graph. 

5. The corresponding table row in the right pane will be highlighted. 

 

7.2 To show/hide Species displayed in the Graph Area: 

1. In the Control Panel, click the Graph tab. 

2. Select/unselect checkboxes in the Visible column in the right pane. 

3. The checked Species are displayed/hidden on the Graph. 

 

7.3 To change the line color of the graph: 

1. In the Control Panel, click the Graph tab. 

2. Click a cell in the Color column in the right pane. 

3. The Pick a Color dialog box appears. 

4. Select a color and click OK button. 
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7.4 To search for species: 

1. In the ControlPanel, in the species search textbox, enter your search word 

2. Click search. 

 

7.5 To convert the graph to a scatter plot: 

You can convert the line chart to a scatter plot and compare the data of an arbitrary pair of 

Species. 

1. In the ControlPanel, select any two Species by ticking the checkboxes in the Visible 

column. 

2. Observe that the graph has been reduced to two curves. 

3. Tick the show scatter plot checkbox. 



Running CellDesigner
TM 

Simulation with ControlPanel 

21 CD10D00 

 

4. Observe that in the new graph the x-axis does not indicate time series any more. 

 

5. Select the reverse checkbox to change the x- and y- axes. 
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8. Save/Open the Results of Simulation (File I/O) 

The result of a simulation is stored in three file types: 

 a model file (*.xml; SBML) 

 a simulation condition file (*.xml; SED-ML) 

 simulation result files (*.txt) 

The model file (SBML) has a one-to-one correspondence with the simulation condition file 

(*_sed.xml). SED xml  

 See also: For details on SED-ML, please refer to the website: http://sed-ml.org  

For example, if you stored the results of two simulations run by model1.xml and 

newmodel.xml into the "models" directory, the contents of the directory will be: 

[models] 

    +------------model1.xml (SBML) 

    +------------model1_sed.xml（ parameters setting for the model 1）  

    +------------[model1]（ the result folder for the model 1）  

                 +--------------result1.txt (simulation result 1) 

                 +--------------result2.txt (simulation result 2) 

                 + 

                ………….. 

    +------------newmodel.xml (a new model) 

    +------------newmodel_sed.xml（ parameters setting for the new model）  

    +------------[newmodel]（ the result folder for the new model）  

                 +-----------------result1.txt（ simulation result 1）  

                 +-----------------result2.txt（ simulation result 2）  

 

8.1 To save a simulation result into files: 

1. Select Save As from the File menu of ControlPanel. 

2. Enter the file name for a simulation result and click the save button. 

3. Then two types of file having extensions ".xml" (SBML), and ".txt" are created. 

8.2 To save simulation conditions into files:  

1. Select Save Condition As from the File menu of ControlPanel. 

2. Enter the file name for simulation conditions and click the save button. 

3. Then two types of file having extensions "SED .xml" and ".txt" are created. 

 See also: [9. Parameter Polymorphism]. 
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8.3 To open a condition and result saved in files: 

1. Select Open Condition from the File menu of CellDesigner. 

2. Select an SED (.xml) file and click the Open button. 

3. The corresponding condition (.xml) file and result files (*.txt) are automatically 

imported so that you can start the ControlPanel and see the result. 
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9. Parameter Polymorphism 

When you run the simulation, it is important to run the simulation with various conditions. 

Parameter polymorphism is the function that allows setting the various conditions for the 

simulation. 

This feature has been introduced in CellDesigner4.2 for advanced users of the simulation 

panel. It allows users to define multiple in-silico experiments on a given model (baseline) by 

defining specific set of parameters and initial conditions (parameter polymorphism) on top of 

the baseline. Users can save the experiments in SED-ML format (http://sed-ml.org) and reload 

then at a later stage in time to execute the in-silico experiments defined on the baseline 

model. 

 Note:  The Simulation Experiment Description Markup Language 

(SED-ML) (http://sed-ml.org) is an XML-based format for encoding simulation experiments, 

following the requirements defined in the Minimum Information About a Simulation 

Experiment (MIASE) guidelines (http://www.biomodels.net/miase/).  SED-ML allows to 

define the model to use, the experimental task to run and which result to produce.  

 See also: For details on MIASE, please refer to the following paper:  

Waltemath et al. Minimum Information About a Simulation Experiment (MIASE). PLoS 

Comput Biol (2011) vol. 7 (4) pp. e1001122 

Changes to Initial Quantity, Time Span, and other parameters can be registered as an 

“experiments” in CellDesigner.  Experiments are displayed in a tree format in the left pane 

and the experimental conditions can be loaded by clicking them.  

 Note: This experiment panel is being hidden in the default view. Please expand to view the 

panel. 

Parameters / conditions that can be saved in the Experiments are as follows: 

 End Time (Time span) 

 Num. of Points (Time span) 

 Exp. (Error tolerance) 

 Solver 

 Initial Quantity (Species) 

 boundary condition (Species) 

 constant (Species) 

 Value (Parameters) 

 constant (Parameters) 

 All items on Change amount 

tab 

 All items on Parameter Scan tab 

 

 

 

http://sed-ml.org/
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9.1 Parameter Polymorphism Workflow 

The following guide takes a step-by-step tour of the Parameter Polymorphisms Panel: 

In summary, the workflow consists of three major steps: 

 Step 1: Define the baseline experiment 

 Step 2: Set the new experiment 

 Step 3: Load and Run the new experiment 

Detail operations for each step are described in the following sections: 

9.2 Workflow Step1: Define the baseline experiment: 

1. Open a model file for simulation 

in the CellDesigner canvas and  

click Simulation menu to open 

the Control Panel. 

 

 

 

 

 

 

 

 

The left hand panel is the new parameter polymorphism panel. It serves as the in 

silico experiment dashboard. 

 Note: By default, the Experiment panel is being collapsed. To display the panel, click to 

un-collapsed it. 
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The default experiment (expt1) is being displayed. This is the baseline experiment.  

Check to see if the baseline experiment runs its simulation OK. 

2. Click Initialize button to set the baseline parameters.  

3. Click Execute the baseline simulation and check the results. 

 

To save the baseline condition, click Save Condition button.  

For the first time, it will prompt for the file path and name to save the experimental 

conditions (SED-ML and results file). 

 Tip: It is recommended to rename the default experiment (expt1) to “baseline” by clicking  

File - Rename Experiment option before saving. 
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9.3 Workflow Step 2: Set the new experiment: 

1. To define a new experiment (by changing parameters or initial concentration of 

species), user can edit the respective panels (shown below).  

In the following example, change the concentration of A to 5 in the [Species] Tab. 

 

2. Click Save Condition button, once the new conditions are defined. 

It will prompt the user for overwrite existing condition.  

Select NO to define a new experimental condition (new parameter polymorphism)  

* Select YES to overwrite the existing condition.  

 

Here select NO to proceed to define the new experiment. 
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3. Specify the new Experiment name. 

 

The conditions are saved with the name specified in the SED-ML file format. 

The new experiment name will apear on the parameter polymorphism panel. 
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4. Select the new experimental name from the left panel, then Click Execute to execute 

the simulation with the new experimental conditions. 

 

By Selection, each condition on the panel will load the specific parameters associated 

with that condition. In this manner, it is possible to define multiple conditions on a 

baseline model. 

 

Once the user has defined all the experiments, You can close the control panel. 

 

 Tip 2:  Once done with the Parameter Polymorphism panel, before closing the Control 

Panel, select the baseline experiment again.  

 See also: [9.5 Tips for Good Practice]  

9.4 Workflow Step 3: Load and Run the new experiment: 

In order to re-load the conditions, the SED-ML file associated with the baseline model can be 

opened. 

1. Select File - Open Condition, then selected the previously saved SED-ML file.  

The confirmation dialog box is shown denoting the original baseline model file with 

which the parameter polymorphisms are associated. 

 CAUTION:  Loading the SED-ML file with a different baseline model can lead to incorrect 

simulation results or cause the Control Panel to crash. 
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9.5 Tips for Good Practice: 

 Tip 1:  DO NOT click on Initialize button on any conditions (except the baseline) as it 

would replace the user defined parameters with the original model baseline value  

 Tip 2:  Once done with the Parameter Polymorphism panel, before closing the Control 

Panel, select the baseline experiment again. This will load the original parameters 

(baseline values) to the model opened on the CellDesigner canvas. This way can ensure 

that the original model file always stores the baseline conditions only while the 

polymorphism conditions are stored in the SED-ML file. 

 

 See also: For details on SED-ML file format, check the SED-ML format specification: 

http://sed-ml.org 

http://sed-ml.org/
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	4. Select Import from the Data menu.
	5. Select the file that you have just edited and click Open button.


	5. Parameter Scan
	5.1 To scan parameters:
	1. Click the Parameter Scan tab.
	2. Check the Scan parameter checkbox.
	3. Select the Initial value or Parameter value option.
	4. Select the name of a parameter to change from the Name list.
	5. Input values into From, To, and Interval for a parameter scan, which correspond to the start value, the end value, and the interval respectively.
	6. Click Execute button to start simulation scanning of the specified parameters.

	5.2 To see the results of parameter scan:
	1. If the message “The simulation was completed” is displayed in the Information dialog box, click OK.
	2. Click the flashing Result tab. (The rightmost tab)
	3. Select the result you want to see and click the Show Graph button.

	5.3 To output the results of parameter scan:
	1. Click Writing.
	2. Specify the file name and the directory to save the file.
	3. The output of the parameter scan results will be saved in text file format.


	6. Interactive Simulation
	6.1 To run interactive simulations:
	1. Click the Interactive Simulation tab.
	2. Select the Initial value or Parameter value option.
	3. To change a parameter, slide each slider bar or input a value into the box on the right side of the slider bar for that parameter.

	6.2 To change the data range of slider bars:
	1. Click the Define Range button.
	2. In the Define Slider Range dialog box, change the minimum and maximum values and click OK button.


	7. Graph Area
	7.1 To highlight a Species in the Graph Area:
	1. In the Control Panel, click the Graph tab.
	2. Click a cell in the Species column in the table.
	3. The corresponding line in the Graph will be highlighted.
	4. Next, click a line in the Graph.
	5. The corresponding table row in the right pane will be highlighted.

	7.2 To show/hide Species displayed in the Graph Area:
	1. In the Control Panel, click the Graph tab.
	2. Select/unselect checkboxes in the Visible column in the right pane.
	3. The checked Species are displayed/hidden on the Graph.

	7.3 To change the line color of the graph:
	1. In the Control Panel, click the Graph tab.
	2. Click a cell in the Color column in the right pane.
	3. The Pick a Color dialog box appears.
	4. Select a color and click OK button.

	7.4 To search for species:
	1. In the ControlPanel, in the species search textbox, enter your search word
	2. Click search.

	7.5 To convert the graph to a scatter plot:
	1. In the ControlPanel, select any two Species by ticking the checkboxes in the Visible column.
	2. Observe that the graph has been reduced to two curves.
	3. Tick the show scatter plot checkbox.
	4. Observe that in the new graph the x-axis does not indicate time series any more.
	5. Select the reverse checkbox to change the x- and y- axes.


	8. Save/Open the Results of Simulation (File I/O)
	8.1 To save a simulation result into files:
	1. Select Save As from the File menu of ControlPanel.
	2. Enter the file name for a simulation result and click the save button.
	3. Then two types of file having extensions ".xml" (SBML), and ".txt" are created.

	8.2 To save simulation conditions into files:
	1. Select Save Condition As from the File menu of ControlPanel.
	2. Enter the file name for simulation conditions and click the save button.
	3. Then two types of file having extensions "SED .xml" and ".txt" are created.

	8.3 To open a condition and result saved in files:
	1. Select Open Condition from the File menu of CellDesigner.
	2. Select an SED (.xml) file and click the Open button.
	3. The corresponding condition (.xml) file and result files (*.txt) are automatically imported so that you can start the ControlPanel and see the result.


	9. Parameter Polymorphism
	9.1 Parameter Polymorphism Workflow
	9.2  Workflow Step1: Define the baseline experiment:
	1. Open a model file for simulation in the CellDesigner canvas and  click Simulation menu to open the Control Panel.         The left hand panel is the new parameter polymorphism panel. It serves as the in silico experiment dashboard.
	2. Click Initialize button to set the baseline parameters.
	3. Click Execute the baseline simulation and check the results.   To save the baseline condition, click Save Condition button.  For the first time, it will prompt for the file path and name to save the experimental conditions (SED-ML and results file).

	9.3 Workflow Step 2: Set the new experiment:
	1. To define a new experiment (by changing parameters or initial concentration of species), user can edit the respective panels (shown below).  In the following example, change the concentration of A to 5 in the [Species] Tab.
	2. Click Save Condition button, once the new conditions are defined. It will prompt the user for overwrite existing condition.  Select NO to define a new experimental condition (new parameter polymorphism)  * Select YES to overwrite the existing condi...
	3. Specify the new Experiment name.
	The conditions are saved with the name specified in the SED-ML file format. The new experiment name will apear on the parameter polymorphism panel.
	4. Select the new experimental name from the left panel, then Click Execute to execute the simulation with the new experimental conditions.
	By Selection, each condition on the panel will load the specific parameters associated with that condition. In this manner, it is possible to define multiple conditions on a baseline model.
	Once the user has defined all the experiments, You can close the control panel.

	9.4 Workflow Step 3: Load and Run the new experiment:
	1. Select File - Open Condition, then selected the previously saved SED-ML file.  The confirmation dialog box is shown denoting the original baseline model file with which the parameter polymorphisms are associated.

	9.5 Tips for Good Practice:


