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1. Introduction 

The “Control Panel” is designed to assist the users to simulate directly from 
CellDesigner controlling the amounts and parameters of the Species. 
Calling directly SBML ODE Solver (http://www.tbi.univie.ac.at/~raim/odeSolver/) from 
CellDesigner, ControlPanel enables you to specify the details of parameters, changing 
amount, conducting parameter search, and interactive simulation with intuitive 
manner. 
 
You can also choose COPASI (http://www.copasi.org/) as an alternative solver. 

See also: Startup Guide (Sections 7.1 & 7.5). 
 

 

 
Sample file used in this document: 
This document uses a sample model “MAPK.xml” provided with SBML ODE Solver. 
This model has been slightly modified from a model obtained from http://sbml.org/models/. 
It has been published in Kholodenko BN. Negative feedback and ultrasensitivity can 
bring about oscillations in the mitogen-activated protein kinase cascades. Eur. J. Biochem. 
267: 1583-1588 (2000). 
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2. Quick Tutorial of Simulation 

Before you start simulation 

Make sure you have the model with all the formulae necessary for the simulation have 
input to the reactions. You can check the KineticLaws in the reaction list: 

See also: Startup Guide (Chapter 7) or CellDesigner Online Help. 

 

KineticLaw 
id name reactants products modifiers math 

J0 J0 MKKK MKKK_P MAPK_PP 
V1 * MKKK / ((1 + pow(MAPK_PP / Ki, n)) 
* (K1 + MKKK)) 

J1 J1 MKKK_P MKKK  V2 * MKKK_P / (KK2 + MKKK_P) 

J2 J2 MKK MKK_P MKKK_P k3 * MKKK_P * MKK / (KK3 + MKK) 

J3 J3 MKK_P MKK_PP MKKK_P k4 * MKKK_P * MKK_P / (KK4 + MKK_P) 

J4 J4 MKK_PP MKK_P  V5 * MKK_PP / (KK5 + MKK_PP) 

J5 J5 MKK_P MKK  V6 * MKK_P / (KK6 + MKK_P) 

J6 J6 MAPK MAPK_P MKK_PP k7 * MKK_PP * MAPK / (KK7 + MAPK) 

J7 J7 MAPK_P MAPK_PP MKK_PP 
k8 * MKK_PP * MAPK_P / (KK8 + 
MAPK_P) 

J8 J8 MAPK_PP MAPK_P  V9 * MAPK_PP / (KK9 + MAPK_PP) 

J9 J9 MAPK_P MAPK  V10 * MAPK_P / (KK10 + MAPK_P) 
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Species 
class id name compartment quantity type initialQuantity 

PROTEIN MKK MKK uVol Amount 280 

PROTEIN MKKK MKKK uVol Amount 90 

PROTEIN MAPK MAPK uVol Amount 280 

PROTEIN MKKK_P MKKK uVol Amount 10 

PROTEIN MKK_P MKK uVol Amount 10 

PROTEIN MKK_PP MKK uVol Amount 10 

PROTEIN MAPK_P MAPK uVol Amount 10 

PROTEIN MAPK_PP MAPK uVol Amount 10 

Parameters 
scope id name value units constant 

local:Reaction(J0) V1  2.5  TRUE 

local:Reaction(J0) Ki  9  TRUE 

local:Reaction(J0) n  1  TRUE 

local:Reaction(J0) K1  10  TRUE 

local:Reaction(J1) V2  0.25  TRUE 

local:Reaction(J1) KK2  8  TRUE 

local:Reaction(J2) k3  0.025  TRUE 

local:Reaction(J2) KK3  15  TRUE 

local:Reaction(J2) V0 V0 111  TRUE 

local:Reaction(J2) K0 K0 1  TRUE 

local:Reaction(J3) k4  0.025  TRUE 

local:Reaction(J3) KK4  15  TRUE 

local:Reaction(J4) V5  0.75  TRUE 

local:Reaction(J4) KK5  15  TRUE 

local:Reaction(J5) V6  0.75  TRUE 

local:Reaction(J5) KK6  15  TRUE 

local:Reaction(J6) k7  0.025  TRUE 

local:Reaction(J6) KK7  15  TRUE 

local:Reaction(J7) k8  0.025  TRUE 

local:Reaction(J7) KK8  15  TRUE 

local:Reaction(J8) V9  0.5  TRUE 

local:Reaction(J8) KK9  15  TRUE 

local:Reaction(J9) V10  0.5  TRUE 

local:Reaction(J9) KK10  15  TRUE 
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To run a basic simulation: 
1. Open a file to simulate by CellDesigner. 
2. Select "ControlPanel" from the "Simulation" menu of CellDesigner.  

 
 
3. Click the “Execute” button on the bottom of the "ControlPanel". 

  
 
By default, the simulation time end is set to 100 and 
number of points to plot is 100. You can enter values 
into "End Time" and "Num.of Points" to change these 
values.  

 
4. Change [End Time] to [1000]. 
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To view the values of the simulation results: 
5. Click the [Table] Tab behind the [Graph] tab on the right panel.  

You can view the results of the simulation in the table format. You can switch 
[species] [fluxes] [parameters] and [compartment] by clicking the relevant tabs. 

 
 

To save an image of the simulation result: 
You can save the graph image into five types of graphical file format:  
BMP, JPEG, PNG, TIFF, and PNM file format: (".bmp", ".jpg", ".png", “.tif” and “.pnm”.) 
 

6. Select "Save Image" from the "File" menu.  
The Image Config Dialog pops up.  

 
 

7. Select “Config” button to specify the graph items such as title, legend and plot 
ranges.  
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8. Select “Save Image” button, then select the file format and specify the file name 
for a graph image.  

 
 

To change the solver to COPASI: 
9. Click the “COPASI” radio button. 
10. Click “Execute”. 
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3. Change the Initial Quantities of Species and Parameter Values 

It is possible to run the simulation with the values in "Species" and "Parameters" tabs 
changed. The values changed in the "ControlPanel" are updated to the corresponding 
values in the "CellDesigner" itself. 
 

To change the parameters for "Species": 
1. Click the "Species" tab.  

 
2. Change the initial values by clicking each blue cell for the values to be modified. 
3. Click the "Execute" button to run the simulation with the new parameters. 

 

To change the parameter values: 
1. Click the "Parameters" tab.  

 
2. Change the initial parameters by clicking each blue cell for the values to be 

modified. 
3. Click the "Execute" button to run the simulation with the new parameters.  
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4. Change Amount for Simulation 

In order to simulate the time course of "Species" resulting from forced expression of a 
gene/genes on a certain time, "ControlPanel" implements the "Change amount" 
functionality. By this functionality you can run a simulation with the amount of 
"Species" changed to a desired value on a specific time. 
Note: COPASI does not support the Change Amount functionality. 
 

To run simulation changing the amount of Species at specific time: 
1. Click the "Change amount" tab. 
2. Check the "Change amount" checkbox. 
3. Input the amount of "Species" corresponding to the time specified at the header of 

the rows in the change amount matrix. 
4. Click the “Execute” button. 

 
 

The change amount matrix can be edited by external software such as MS Excel by 
exporting the matrix to a CSV file. The CSV file edited outside can be imported to 
“ControlPanel”. 
 

To export and import the Change amount matrix: 
1. Select "Export" from the "Data" menu. 
2. Enter a file name and click the "Save" button.  

(A CSV file will be created with the specified file name.) 
3. Open the CSV file using other software such as MS Excel, edit values, and save 

them.  
4. Select "Import" from the "Data" menu. 
5. Select the file that you have just edited and click the "Open" button. 
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e.g. an example of .CSV file exported from Control Panel.  
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5. Parameter Scan 

You can run simulations in a batch job to scan parameters. By setting the range and 
interval of each parameter to scan, "ControlPanel" runs the simulation with each 
parameter changing within the specified range with the value incremented by the 
specified interval. 
 

To scan parameters: 
1. Click the "Parameter Scan" tab. 
2. Check the "Scan parameter" checkbox. 
3. Select the "Initial value" or "Parameter value" option. 
4. Select the name of a parameter to change from the list. 
5. Input values into "From", "To", and "Interval" for a parameter scan, which 

correspond to the start value, the end value, and the interval respectively. 
6. Click [Execute] button to start simulation scanning the specified parameters. 

 
 

In case you check two "Scan parameter" checkboxes, you can scan two parameters. The 
simulations are executed using the combination of the two parameters. 

 

To see the results of parameter scan: 
1. When the message “The simulation was completed” is displayed,  

click the blinking "Result" tab. 
2. Select the result you wish to see and click the "Show Graph" button. 
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6. Interactive Simulation 

"ControlPanel" allow you to see real-time results of simulations. You should use 
"Interactive simulation" for this purpose. 
 

To run interactive simulations: 
1. Click the "Interactive Simulation" tab. 
2. Select the "Initial value" or "Parameter value" option. 
3. To change a parameter, slide each slider bar or input a value into a box on the right 

side of the slider bar for the parameter. 

 

 
The minimum and maximum values of slider bar were automatically defined 
based on the initial values of SBML. However, you can change the data range of 
slider bars. 
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To change the data range of slider bars: 
1. Click the "Define Range" button. 
2. Change the minimum and maximum values and click the "OK" button. 
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7. Plot area 

To highlight a plot and a node: 
 Click a cell of the "Species" column in the right panel 

 (the corresponding plot will be highlighted). 
 Click on a plot  

(the corresponding table data on the right panel will be highlighted). 

 
 

To change the graphs plot displayed in the plot area: 
1. Check checkboxes in the "Visible" column in the right panel. 
2. The graphs plot of checked species is displayed. 

 
 
Note: [Select All] / [Unselect All] toggle button is available for batch operation. (just above the search 
button) 
 

To change the color of a plot: 
1. Click a cell in the "Color" column on the right panel.  

("Pick a color" dialog appears) 
2. Select a color and click the "OK" button. 
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Search for Species: 
To search for a specific "Species", enter a keyword into "species search" textbox located 
on the lower right portion of "ContorolPanel", and click the "search" button. 

 
 

Show Scatter Plot: 
You can plot and compare the data of an arbitrary pair of Species. 
1. In the ControlPanel, select any two Species by ticking the checkboxes in the 

“Visible” column. 
2. Observe that the graph has been reduced to two curves. 

 
3. Tick the ”show scatter plot” checkbox. 
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4. Observe that in the new graph the x-axis does not indicate time series any more. 

 
5. Select the “reverse” checkbox to change the x- and y- axes. 
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8. File I/O 

The result of a simulation is stored in three types of file: the model to be used (SBML), 
the parameters to be set (*.sim), and the simulation result (*.txt). The model (SBML) 
has a one-to-one correspondence with the parameters (*.sim). For example, if you stored 
the results of two simulations run by model1.xml and newmodel.xml into the "models" 
directory, the contents of the directory will be: 
 

[models] 
    +------------model1.xml (SBML) 
    +------------model1.sim（parameters setting for the model 1） 
    +------------[model1]（the result folder for the model 1） 
                 +--------------result1.txt (simulation result 1) 
                 +--------------result2.txt (simulation result 2) 
                 + 
                ………….. 
    +------------newmodel.xml (a new model) 
    +------------newmodel.sim（parameters setting for the new model） 
    +------------[newmodel]（the result folder for the new model） 
                 +-----------------result1.txt（simulation result 1） 
                 +-----------------result2.txt（simulation result 2） 

 

To save a simulation result into files: 
1. Select "Save As" from the "File" menu of “ControlPanel”. 
2. Enter the file name for a simulation result and click the "save" button. 
3. Then three types of file having extensions ".xml", ".sim", and ".txt" are created. 
 

To open a result saved in files: 
1. Select "Open" from the File menu of CellDesigner. 
2. Select "SBML file" and click the "open" button. 
3. The corresponding ".sim" file and result files are automatically imported, so you can 

start the "ControlPanel" and see the result. 
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